52º North coordinates bug

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

52º North coordinates bug

legramo
It seems to be a bug in 52º North related to the way it returns the coordinates. In order to provide an example, i have inserted a point with the coordinates:
longitude: -3.605593
latitude: 37.163285

After executing "GetFeatures" via API, 52º North provides:

"geometry" : {
  "type" : "Point",
  "coordinates" : [37.163285, -3.605593]
}

Unfortunately the correct answer would be just the opposite [-3.605593, 37.163285], it means first longitude and after latitude (based on http://geojson.org).

Did anybody get the same error? Thanks in advance.

Best
Reply | Threaded
Open this post in threaded view
|

Re: 52º North coordinates bug

debard
Je suis absent du bureau du 04/02/2017 au 13/02/2017 compris.
Je n'ai pas accès à ma messagerie pendant cette période. Je prendrai connaissance de votre message à mon retour.

Cordialement
Reply | Threaded
Open this post in threaded view
|

Re: 52º North coordinates bug

Carsten Hollmann
In reply to this post by legramo
Hi,

the JSON binding/coding of the 52°North SOS uses the axes order of the
coordinates as defined in the EPSG registry (http://www.epsg-registry.org/).

For EPSG 4326 the axes order is "latitude longitude".

Best,
Carsten
_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Please respect our mailing list guidelines:
http://52north.org/resources/mailing-lists-and-forums/guidelines