/52n-OXF-WS/RESTful/sos/ servlet not accessible

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

/52n-OXF-WS/RESTful/sos/ servlet not accessible

Sana CES
Hi,


I try to test the RestfulSOS application, so I have built the web application and runned it.
The project has been succefully built, but it stills the problem of browsing the application! I copied the war file into the web apps folder
and the REST SOS folder has been built, but I can't access to the servlet.
I tried :
http://localhost:8080/52n-OXF-WS/ but it outputs just the miniOM.owl file (like the figure that I attached with this msg).

I tried also to type: http://localhost:8080/52n-OXF-WS/RESTful/sos but msg of error has been
outputed like this:
type Rapport d'état
message /52n-OXF-WS/RESTful/sos
description La ressource demandée (/52n-OXF-WS/RESTful/sos) n'est pas
disponible.

So what's the problem Plz? Why I couldn't access to the servlet ? knowing that all the classes are succesfully compiled!!

Thnx for Your prompt response and help that I really need.
Best Regards,
Sana.

Reply | Threaded
Open this post in threaded view
|

Re: /52n-OXF-WS/RESTful/sos/ servlet not accessible

Sana CES
It's worked finally, I restart Eclipse and it works :)
But this message has been outputed for every request:

OGC Web Service returned exception:
Exception: InvalidParameterValue
Locator: procedure
Exception text: The value of the sensorID parameter is incorrect. Please check the capabilities response document for valid sensor Ids!
Sended request was:
<sos:DescribeSensor xmlns:sos="http://www.opengis.net/sos/1.0" service="SOS" version="1.0.0" outputFormat="text/xml;subtype="sensorML/1.0.1""> <sos:procedure>MW%20-%20Langballigau%20(9610015)</sos:procedure> </sos:DescribeSensor>

and also:

type Rapport d'exception

message

description Le serveur a rencontré une erreur interne () qui l'a empêché de satisfaire la requête.

exception

javax.servlet.ServletException
        org.n52.oxf.rest.sos.RestSosFrontend.doGet(RestSosFrontend.java:462)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:802)



How can I resolve this? should I modify the URLs or what? are there a guid for this?
Cheers,
Sana.
Reply | Threaded
Open this post in threaded view
|

Re: /52n-OXF-WS/RESTful/sos/ servlet not accessible

Eike Hinderk Jürrens
Hi Sana,
the answer is in the error message clearly stated.
You used a sensorId that is unknown to the SOS instance. Because of that
your request can not the answered.
So, please check the capabilities of the used SOS instance and use one
of the returned procedureIds in your requests.

Am 24.05.2011 22:37, schrieb Sana CES:
> It's worked finally, I restart Eclipse and it works :)
> But this message has been outputed for every request:
>
> OGC Web Service returned exception:
> Exception: InvalidParameterValue
> Locator: procedure
> Exception text: The value of the sensorID parameter is incorrect. Please
> check the capabilities response document for valid sensor Ids!
Here is the explanation of the error!

> Sended request was:
> <sos:DescribeSensor xmlns:sos="http://www.opengis.net/sos/1.0" service="SOS"
> version="1.0.0" outputFormat="text/xml;subtype="sensorML/1.0.1"">
> <sos:procedure>MW%20-%20Langballigau%20(9610015)</sos:procedure>
Here is the broken id! It seems like an URL en/decoding issue.

> </sos:DescribeSensor>
>
> How can I resolve this? should I modify the URLs or what? are there a guid
> for this?
> Cheers,
> Sana.
Kind regards,
Eike

--
Eike Hinderk Jürrens
52° North Initiative for Geospatial Open Source Software GmbH
Martin-Luther-King-Weg 24
48155 Münster, Germany
E-Mail: [hidden email]
Fon: +49-(0)-251–396371-33
Fax: +49-(0)-251–396371-11
http://52north.org/
General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
Local Court Muenster HRB 10849

_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: /52n-OXF-WS/RESTful/sos/ servlet not accessible

Sana CES
Thnx Eike for Your replay, but the problem is that this HTTP-500 error
appeared for every request I do!
I didn't know what's the problem? and if I should modify the version of
SOS to make it work fine..
Any suggestions Plz??

Thnx,
Sana.
On Mon, 30 May 2011 00:56:56 -0700 (PDT), Eike Hinderk Jürrens [via 52°
North - Sensor Web Community Forum] wrote:

> Hi Sana,
> the answer is in the error message clearly stated.
> You used a sensorId that is unknown to the SOS instance. Because of
> that
> your request can not the answered.
> So, please check the capabilities of the used SOS instance and use
> one
> of the returned procedureIds in your requests.
>
> Am 24.05.2011 22:37, schrieb Sana CES:
>> It's worked finally, I restart Eclipse and it works :)
>> But this message has been outputed for every request:
>>
>> OGC Web Service returned exception:
>> Exception: InvalidParameterValue
>> Locator: procedure
>> Exception text: The value of the sensorID parameter is incorrect.
> Please
>> check the capabilities response document for valid sensor Ids!
> Here is the explanation of the error!
>
>> Sended request was:
>>  version="1.0.0" outputFormat="text/xml;subtype="sensorML/1.0.1"">
>> MW%20-%20Langballigau%20(9610015)
> Here is the broken id! It seems like an URL en/decoding issue.
>
>>
>>
>> How can I resolve this? should I modify the URLs or what? are there
> a guid
>> for this?
>> Cheers,
>> Sana.
> Kind regards,
> Eike
>
> --
> Eike Hinderk Jürrens
> 52° North Initiative for Geospatial Open Source Software GmbH
> Martin-Luther-King-Weg 24
> 48155 Münster, Germany
> E-Mail: [hidden email] [2]
> Fon: +49-(0)-251–396371-33
> Fax: +49-(0)-251–396371-11
> http://52north.org/ [3]
> General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
> Local Court Muenster HRB 10849
>
> _______________________________________________
> SWE mailing list
> [hidden email] [4]
> http://list.52north.org/mailman/listinfo/swe [5]
> http://sensorweb.forum.52north.org [6]
>
> -------------------------
>
> If you reply to this email, your message will be added to the
> discussion below:
>
> http://sensorweb.forum.52north.org/52n-OXF-WS-RESTful-sos-servlet-not-accessible-tp2980782p3001138.html
> [7]
>  To unsubscribe from /52n-OXF-WS/RESTful/sos/ servlet not accessible,
> click here [8].
>
> Links:
> ------
> [1] http://www.opengis.net/sos/1.0
> [2]
>
> http://webmail.exclusivehosting.net/user/SendEmail.jtp?type=node&node=3001138&i=0
> [3] http://52north.org/
> [4]
>
> http://webmail.exclusivehosting.net/user/SendEmail.jtp?type=node&node=3001138&i=1
> [5] http://list.52north.org/mailman/listinfo/swe
> [6] http://sensorweb.forum.52north.org
> [7]
>
> http://sensorweb.forum.52north.org/52n-OXF-WS-RESTful-sos-servlet-not-accessible-tp2980782p3001138.html
> [8]
>
>

Reply | Threaded
Open this post in threaded view
|

Re: /52n-OXF-WS/RESTful/sos/ servlet not accessible

Sana CES
In reply to this post by Eike Hinderk Jürrens
Hi again,

I checked from the capabilities of the used SOS instance before sending
the request, it exists really in the capabilities document but it
returns the same error! this error is always appeared for every sensor
request!!Plz what's the problem? how can I resolve it? it can be from my
installation for example? I really don't know what should I do!!
Any help will be soooo appreciated.

Regards,
Sana.
On Mon, 30 May 2011 00:56:56 -0700 (PDT), Eike Hinderk Jürrens [via 52°
North - Sensor Web Community Forum] wrote:

> Hi Sana,
> the answer is in the error message clearly stated.
> You used a sensorId that is unknown to the SOS instance. Because of
> that
> your request can not the answered.
> So, please check the capabilities of the used SOS instance and use
> one
> of the returned procedureIds in your requests.
>
> Am 24.05.2011 22:37, schrieb Sana CES:
>> It's worked finally, I restart Eclipse and it works :)
>> But this message has been outputed for every request:
>>
>> OGC Web Service returned exception:
>> Exception: InvalidParameterValue
>> Locator: procedure
>> Exception text: The value of the sensorID parameter is incorrect.
> Please
>> check the capabilities response document for valid sensor Ids!
> Here is the explanation of the error!
>
>> Sended request was:
>>  version="1.0.0" outputFormat="text/xml;subtype="sensorML/1.0.1"">
>> MW%20-%20Langballigau%20(9610015)
> Here is the broken id! It seems like an URL en/decoding issue.
>
>>
>>
>> How can I resolve this? should I modify the URLs or what? are there
> a guid
>> for this?
>> Cheers,
>> Sana.
> Kind regards,
> Eike
>
> --
> Eike Hinderk Jürrens
> 52° North Initiative for Geospatial Open Source Software GmbH
> Martin-Luther-King-Weg 24
> 48155 Münster, Germany
> E-Mail: [hidden email] [2]
> Fon: +49-(0)-251–396371-33
> Fax: +49-(0)-251–396371-11
> http://52north.org/ [3]
> General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
> Local Court Muenster HRB 10849
>
> _______________________________________________
> SWE mailing list
> [hidden email] [4]
> http://list.52north.org/mailman/listinfo/swe [5]
> http://sensorweb.forum.52north.org [6]
>
> -------------------------
>
> If you reply to this email, your message will be added to the
> discussion below:
>
> http://sensorweb.forum.52north.org/52n-OXF-WS-RESTful-sos-servlet-not-accessible-tp2980782p3001138.html
> [7]
>  To unsubscribe from /52n-OXF-WS/RESTful/sos/ servlet not accessible,
> click here [8].
>
> Links:
> ------
> [1] http://www.opengis.net/sos/1.0
> [2]
>
> http://webmail.exclusivehosting.net/user/SendEmail.jtp?type=node&node=3001138&i=0
> [3] http://52north.org/
> [4]
>
> http://webmail.exclusivehosting.net/user/SendEmail.jtp?type=node&node=3001138&i=1
> [5] http://list.52north.org/mailman/listinfo/swe
> [6] http://sensorweb.forum.52north.org
> [7]
>
> http://sensorweb.forum.52north.org/52n-OXF-WS-RESTful-sos-servlet-not-accessible-tp2980782p3001138.html
> [8]
>
>

Reply | Threaded
Open this post in threaded view
|

Re: /52n-OXF-WS/RESTful/sos/ servlet not accessible

N4zroth
Hello,
I'm facing the exact same problem, have you (or has anybody) resolved that yet?
Thank you
Reply | Threaded
Open this post in threaded view
|

Re: /52n-OXF-WS/RESTful/sos/ servlet not accessible

Sana CES
Hi,

I resolved this problem by right clicking on the  miniOM.owl link (that is illustrated in the attached figure above http://sensorweb.forum.52north.org/52n-OXF-WS-RESTful-sos-servlet-not-accessible-td2980782.html ) and I opened it in another tab, then, in the opened tab I replaced the URL by deleting  miniOM.owl and writing "RESTful/sos/ ".
Hope that can help You.

Cheers,
Sana.
Reply | Threaded
Open this post in threaded view
|

Re: /52n-OXF-WS/RESTful/sos/ servlet not accessible

N4zroth
Thank you, but I actually meant the error about the wrong sensor ID. I know the error is clearly stated but as the code isn't documented that much, I can't see where to make the right changes. It would be nice if anyone knew how to solve that problem. Thanks.