Including contact information with InsertSensor

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Including contact information with InsertSensor

TSlawecki
I am currently implementing a network with separate station and sensor procedures, so I have (e.g.)

procedure epaiwpp:station:njdep:99999999 (station)

procedure epaiwpp:sensor:njdep:99999999:temperature (sensor)

I would like to include contact information in the station procedure, and am trying to do that by adding an sml:contact block. However, I get the following error

<ows:ExceptionText>[XmlBeans validation error:] Expected elements 'parameters@http://www.opengis.net/sensorML/1.0.1 components@http://www.opengis.net/sensorML/1.0.1 positions@http://www.opengis.net/sensorML/1.0.1 connections@http://www.opengis.net/sensorML/1.0.1' instead of 'contact@http://www.opengis.net/sensorML/1.0.1' here in element System@http://www.opengis.net/sensorML/1.0.1</ows:ExceptionText>

with my current xml, which is available at https://limno.sharefile.com/d-sca636e66f234e589. Please advise on how to make this work.

Thanks,

Tad

Reply | Threaded
Open this post in threaded view
|

Re: Including contact information with InsertSensor

Carsten Hollmann
Hi Tad,

as the exception says, the 'contact' element is defined at the wrong
position in your System. The

The 'contact' element shall be defined right after the 'capabilities'
elements.

Best,
Carsten
_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Please respect our mailing list guidelines:
http://52north.org/resources/mailing-lists-and-forums/guidelines