Problem with RESTfull API

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with RESTfull API

debard
Hi SOS users,

I have two problems with my sos server (52 degree North - last version) and
client helgoland (last version).

First when i send the request:
http://xxxxxxxxxxxxx:8080/52n-sos-webapp/api/timeseries/2/getData.png?legend=true,  
the response is:

{"statusCode":500,"userMessage":"Unexpected Exception
occured.","developerMessage":"Size of designs and metadatas do not match:
#Timeseries: 0 vs. #Metadatas: 1","reason":"Internal Server Error"}


Second, with the helgoland (last version) , it's impossible to show a
ChartType for a phenomenonType with 'bar'. I modified the
"config-rendering-hint.json" file and "config-task-prerendering.json"
without success.
 
Maybe you can send me an idea. Thank you for your help
Best regards,




--
Sent from: http://sensorweb.forum.52north.org/
_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Please respect our mailing list guidelines:
http://52north.org/resources/mailing-lists-and-forums/guidelines
Reply | Threaded
Open this post in threaded view
|

Re: Problem with RESTfull API

debard
This post was updated on .
Sorry for the inconvenience, but do you have any suggestions about my post ?
thank you

and now i show in my last request:
xxxxxxxxxx:8080/52n-sos-webapp/api/datasets/4/getData.png?expanded=true&format=flot&generalize=true&locale=de×pan=2017-10-10T11:23:35%2B02:00%2F2017-10-10T20:42:26%2B02:00

{"statusCode":404,"userMessage":"No pre-rendered chart found for datasetId '4 (qualifier: getData)'.","reason":"Not Found"}

--
Sent from: http://sensorweb.forum.52north.org/
_______________________________________________
SWE mailing list
SWE@52north.org
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Please respect our mailing list guidelines:
http://52north.org/resources/mailing-lists-and-forums/guidelines
Reply | Threaded
Open this post in threaded view
|

Re: Problem with RESTfull API

Carsten Hollmann
Hi,

in the version of the REST-API, used in the SOS 4.4.0, was an issue when
querying with parameter "legend=true".
The SOS 4.4.0 uses an alpha release version of the REST-API  2.x which
provides the rendering hints in another way.

This issues are fixed in the current version of the SOS bundle 4.4.1.
The query with legend-parameter works and if you have defined the
rendering hints for a dataset as bar, it would be rendered as bar in
Helgoland.

Please have a look at the current version 4.4.1 of the SOS bundle which
you can download from here:

https://github.com/52North/SOS/releases/tag/v4.4.1

Best,
Carsten
_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Please respect our mailing list guidelines:
http://52north.org/resources/mailing-lists-and-forums/guidelines
Reply | Threaded
Open this post in threaded view
|

Re: Problem with RESTfull API

debard
Hi,
I tested today and obviously all fonctionnalities is back.
many thanks,
Best,




--
Sent from: http://sensorweb.forum.52north.org/
_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Please respect our mailing list guidelines:
http://52north.org/resources/mailing-lists-and-forums/guidelines