SensorWebClient build problem

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

SensorWebClient build problem

sakura
Hi,

I'am trying to build the SensorWebClient 3.2.0 to access to timeseries data stored within SOS.
I downloaded  SensorWebClient develope branch.
I follow the steps from [1].

In steps2
I configure my SOS instances within src/main/webapp/ds/sos-instances.data.xml

but next step "Copy ${project_root}/sensorwebclient-build-example.properties to ${user.home}/sensorwebclient-build-dev.properties and adjust settings (alternatively, you can configure all properties in the root pom.xml)"

And actually I couldn't find the file"sensorwebclient-build-dev.properties" in ${user.home},
so it showed "Build Failure" when I use the maven to build the .war file that it couldn't find sensorwebclient-build-dev.properties.

Is any idea to deal with it?

Thank you very much!

Sakura

[1] https://wiki.52north.org/bin/view/SensorWeb/SensorWebClientInstallationGuide

Reply | Threaded
Open this post in threaded view
|

Re: SensorWebClient build problem

Daniel Nüst - 52N
Am 27.03.2014 08:59, schrieb sakura:

> I'am trying to build the SensorWebClient 3.2.0 to access to timeseries data
> stored within SOS.
> I downloaded  SensorWebClient develope branch.
> I follow the steps from [1].
>
> In steps2
> I configure my SOS instances within
> src/main/webapp/ds/sos-instances.data.xml
>
> but next step "Copy ${project_root}/sensorwebclient-build-example.properties
> to ${user.home}/sensorwebclient-build-dev.properties and adjust settings
> (alternatively, you can configure all properties in the root pom.xml)"
>
> And actually I couldn't find the file"sensorwebclient-build-dev.properties"
> in ${user.home},

Thy it says "Copy X to Y", because you have to copy the
...-example.properties file to your user home directory and rename it to
-dev.properties.

Is the file ${project_root}/sensorwebclient-build-example.properties there?

/Daniel

> so it showed "Build Failure" when I use the maven to build the .war file
> that it couldn't find sensorwebclient-build-dev.properties.
>
> Is any idea to deal with it?
>
> Thank you very much!
>
> Sakura
>
> [1]
> https://wiki.52north.org/bin/view/SensorWeb/SensorWebClientInstallationGuide
>
>
>
>
>
> --
> View this message in context: http://sensorweb.forum.52north.org/SensorWebClient-build-problem-tp4027179.html
> Sent from the 52° North - Sensor Web Community Forum mailing list archive at Nabble.com.
> _______________________________________________
> SWE mailing list
> [hidden email]
> http://list.52north.org/mailman/listinfo/swe
> http://sensorweb.forum.52north.org
>


--
Daniel Nüst
52°North Initiative for Geospatial Open Source Software GmbH
Martin-Luther-King-Weg 24
48155 Münster, Germany
E-Mail: [hidden email]
Fon: +49-(0)-251–396371-36
Fax: +49-(0)-251–396371-11

http://52north.org/
Twitter: @FiveTwoN

General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
Local Court Muenster HRB 10849
_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: SensorWebClient build problem

sakura
Hi,

sorry for that I confused the meaning.

I used the "mvn clean install -P env-dev" and it  started building.
But there shows an error here [1].

It failed to load the file.
How can I save this problem?

Thank you!

Sakura


[1]
[INFO] Sensor Web Client External Tools .................. SUCCESS [  2.722 s]
[INFO] Shared SES Components ............................. SUCCESS [04:32 min]
[INFO] SES Server Components ............................. SUCCESS [ 38.930 s]
[INFO] SES RPC Bindings .................................. SUCCESS [  1.007 s]
[INFO] SOS Server Components ............................. SUCCESS [  2.243 s]
[INFO] SOS RPC Bindings .................................. SUCCESS [  0.965 s]
[INFO] SOS Rest Interface ................................ SUCCESS [ 17.689 s]
[INFO] User Interface .................................... SUCCESS [09:19 min]
[INFO] Connector for an ArcGIS SOS extension. ............ SUCCESS [ 11.022 s]
[INFO] SOS Hydrology Profil Connector .................... SUCCESS [  0.849 s]
[INFO] Sensor Web Client Web Application ................. SUCCESS [14:38 min]
[INFO] RESTful Timeseries Web Application ................ FAILURE [  1.426 s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 31:15 min
[INFO] Finished at: 2014-03-27T16:38:07+08:00
[INFO] Final Memory: 76M/440M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-resources-plugin:2
.6:resources (default-resources) on project restful-timeseries-webapp: Error loa
ding property file 'C:\Users\igis\restful-timeseries-build-dev.properties' -> [H
elp 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit
ch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please rea
d the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionE
xception
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command

[ERROR]   mvn <goals> -rf :restful-timeseries-webapp  
Reply | Threaded
Open this post in threaded view
|

Re: SensorWebClient build problem

Daniel Nüst - 52N
Am 27.03.2014 09:59, schrieb sakura:
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-resources-plugin:2
> .6:resources (default-resources) on project restful-timeseries-webapp: Error
> loa
> ding property file 'C:\Users\igis\restful-timeseries-build-dev.properties'
> -> [H
> elp 1]
> [ERROR]

Please read the error message carefully. Does the file
"C:\Users\igis\restful-timeseries-build-dev.properties" actually exist?

/Daniel

PS:
http://52north.org/resources/mailing-list-and-forums/mailinglist-guidelines

--
Daniel Nüst
52°North Initiative for Geospatial Open Source Software GmbH
Martin-Luther-King-Weg 24
48155 Münster, Germany
E-Mail: [hidden email]
Fon: +49-(0)-251–396371-36
Fax: +49-(0)-251–396371-11

http://52north.org/
Twitter: @FiveTwoN

General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
Local Court Muenster HRB 10849
_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: SensorWebClient build problem

Henning Bredel-4
In reply to this post by sakura
sakura,

currently you build both sensorwebclient-webapp and
restful-timeseries-webapp. MEchanisms are similar, but the

   restful-timeseries-example.properties

is located in the respective module instead. Just copy both properties
files in your user home and it should work. Otherwise you should be fine
by building with

   mvn clean install -pl sensorwebclient-webapp -Penv-dev

Hope this helps

   Henning

Am 27.03.2014 09:59, schrieb sakura:

> Hi,
>
> sorry for that I confused the meaning.
>
> I used the "mvn clean install -P env-dev" and it  started building.
> But there shows an error here [1].
>
> It failed to load the file.
> How can I save this problem?
>
> Thank you!
>
> Sakura
>
>
> [1]
> [INFO] Sensor Web Client External Tools .................. SUCCESS [  2.722
> s]
> [INFO] Shared SES Components ............................. SUCCESS [04:32
> min]
> [INFO] SES Server Components ............................. SUCCESS [ 38.930
> s]
> [INFO] SES RPC Bindings .................................. SUCCESS [  1.007
> s]
> [INFO] SOS Server Components ............................. SUCCESS [  2.243
> s]
> [INFO] SOS RPC Bindings .................................. SUCCESS [  0.965
> s]
> [INFO] SOS Rest Interface ................................ SUCCESS [ 17.689
> s]
> [INFO] User Interface .................................... SUCCESS [09:19
> min]
> [INFO] Connector for an ArcGIS SOS extension. ............ SUCCESS [ 11.022
> s]
> [INFO] SOS Hydrology Profil Connector .................... SUCCESS [  0.849
> s]
> [INFO] Sensor Web Client Web Application ................. SUCCESS [14:38
> min]
> [INFO] RESTful Timeseries Web Application ................ FAILURE [  1.426
> s]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 31:15 min
> [INFO] Finished at: 2014-03-27T16:38:07+08:00
> [INFO] Final Memory: 76M/440M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-resources-plugin:2
> .6:resources (default-resources) on project restful-timeseries-webapp: Error
> loa
> ding property file 'C:\Users\igis\restful-timeseries-build-dev.properties'
> -> [H
> elp 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
> swit
> ch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please
> rea
> d the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionE
> xception
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with the
> command
>
> [ERROR]   mvn <goals> -rf :restful-timeseries-webapp
>
>
>
> --
> View this message in context: http://sensorweb.forum.52north.org/SensorWebClient-build-problem-tp4027179p4027183.html
> Sent from the 52° North - Sensor Web Community Forum mailing list archive at Nabble.com.
> _______________________________________________
> SWE mailing list
> [hidden email]
> http://list.52north.org/mailman/listinfo/swe
> http://sensorweb.forum.52north.org
>

_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: SensorWebClient build problem

Dana
In reply to this post by Daniel Nüst - 52N
Hi Daniel,
   Recently I've also working on the sensorwebclient building and I want to know what's the difference between project.root & user.home. Thanks for your help.
Best regards,
Dana
Reply | Threaded
Open this post in threaded view
|

Re: SensorWebClient build problem

Dana
In reply to this post by Daniel Nüst - 52N
Hi Daniel,
    I posted a message before and now I want to repost a message and have my problems described clearly. I've downloaded the sensorwebclient project from[1] and I follow the instructions from[2].
     But when I configured my sos instance I couldn't find the file "src/main/webapp/ds/sos-instances.data.xml" in ${project_root}src/main/resources/webapp; instead I only have folders ${project_root}/src/main/assembly. So I don't know where the xml file is exactly.
     Besides I copied the ${project_root}/sensorwebclient-build-example.properties to my user_home(that is, c:\users\myusername) and renamed it with "sensorwebclient-build-dev.properties". But when I built it with the maven command "mvn clean install" it warns with the following error message:

Above are the two problems I meet with now.I'm here to turn to you for help.Looking forward to your feedback.Thank you.
Best regards,
Dana
[1]https://github.com/52North/SensorWebClient
[2]https://wiki.52north.org/SensorWeb/SensorWebClientInstallationGuide