jsClient doesn't display observations

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

jsClient doesn't display observations

Alberto

Hi, 

I'm trying to set up jsClient v1.0.0 reading from SOS server 4.3.7.
It works well until I try to display observations. It responds with:
"You have selected no timeseries, the selected timeseries have no
values in the given time range or the timeseries are hidden".
What am I doing wrong?

- Timeseries api work well: I can read phenomena, stations,
observations, etc.. (with browser or curl).
- jsClient displays the list of phenomena to choose.
- There are not No particular errors in the http session or in the sos
server.

Follow my settings.json:

{
    "selectedLineWidth": 4,
    "commonLineWidth": 1,
    "restApiUrls": {
        "http://some.host.com/sos/api/v1/": "MySOS"
    },
    "defaultProvider": {
        "serviceID": "1",
        "apiUrl": "http://some.host.com/sos/api/v1/"
    },
    "chartOptions":{
        "yaxis":{
            "tickDecimals" : 2
        }
    }
}

... nothing special.

Regards

Alberto
_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Please respect our mailing list guidelines:
http://52north.org/resources/mailing-lists-and-forums/guidelines
Reply | Threaded
Open this post in threaded view
|

Re: jsClient doesn't display observations

Alberto

Solved,

the problem was in the setting file. The key of the restApiUrls is used
as identifier hence it can't contain spaces or other "special"
characters.

Regards

Alberto

On Tue, 2016-07-19 at 12:58 +0200, Alberto wrote:

> Hi, 
>
> I'm trying to set up jsClient v1.0.0 reading from SOS server 4.3.7.
> It works well until I try to display observations. It responds with:
> "You have selected no timeseries, the selected timeseries have no
> values in the given time range or the timeseries are hidden".
> What am I doing wrong?
>
> - Timeseries api work well: I can read phenomena, stations,
> observations, etc.. (with browser or curl).
> - jsClient displays the list of phenomena to choose.
> - There are not No particular errors in the http session or in the
> sos
> server.
>
> Follow my settings.json:
>
> {
>     "selectedLineWidth": 4,
>     "commonLineWidth": 1,
>     "restApiUrls": {
>         "http://some.host.com/sos/api/v1/": "MySOS"
>     },
>     "defaultProvider": {
>         "serviceID": "1",
>         "apiUrl": "http://some.host.com/sos/api/v1/"
>     },
>     "chartOptions":{
>         "yaxis":{
>             "tickDecimals" : 2
>         }
>     }
> }
>
> ... nothing special.
>
> Regards
>
> Alberto
_______________________________________________
SWE mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/swe
http://sensorweb.forum.52north.org
Please respect our mailing list guidelines:
http://52north.org/resources/mailing-lists-and-forums/guidelines